re = /([1-9][0-9]*[eE][1-9][0-9]*|(([1-9][0-9]*\.)|(\.[0-9]+))([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?)/m
str = 'Matches
3.
3.3
3.3e2
3.3e-1
.1e1
1.11e12
1.3e-1
.1e1
.2e-14
5E6
No match
3
E9
.e3
7E
# Bla bla Saker
Exponent:
[eE][\\-\\+]?[1-9][0-9]*
Siffra:
[1-9][0-9]*
# Förklaring
Stora parantesen
Alt1:
Siffra sen E utan punkt (slutar)
[1-9][0-9]*[eE][1-9][0-9]*
Alt2:
(([1-9][0-9]*\\.)|(\\.[0-9]+))([0-9]*)?([eE][\\-\\+]?[1-9][0-9]*)?
vänsta sidan innan ([0-9]*)?
parantes (([1-9][0-9]*\\.)|(\\.[0-9]+))
Alt1: ([1-9][0-9]*\\.)
Non Zero leading- siffra sen punkt
Alt2: (\\.[0-9]+)
Punkt sen (måste) siffra
Högra sidan ([0-9]*)?([eE][\\-\\+]?[1-9][0-9]*)?
([0-9]*)?
kanske siffra
([eE][\\-\\+]?[1-9][0-9]*)?
kanske exponent
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end