import re
regex = re.compile(r"([1-9][0-9]*[eE][1-9][0-9]*|(([1-9][0-9]*\.)|(\.[0-9]+))([0-9]*)?([eE][\-\+]?[1-9][0-9]*)?)", flags=re.MULTILINE)
test_str = ("Matches\n"
"3.\n"
"3.3\n"
"3.3e2\n"
"3.3e-1\n"
".1e1\n"
"1.11e12\n"
"1.3e-1\n"
".1e1\n"
".2e-14\n"
"5E6\n\n"
"No match\n"
"3\n"
"E9\n"
".e3\n"
"7E\n\n"
"# Bla bla Saker\n"
"Exponent:\n"
"[eE][\\-\\+]?[1-9][0-9]*\n\n"
"Siffra:\n"
"[1-9][0-9]*\n\n"
"# Förklaring\n"
"Stora parantesen\n"
" Alt1:\n"
" Siffra sen E utan punkt (slutar)\n"
" [1-9][0-9]*[eE][1-9][0-9]*\n"
" Alt2:\n"
" (([1-9][0-9]*\\.)|(\\.[0-9]+))([0-9]*)?([eE][\\-\\+]?[1-9][0-9]*)?\n"
" vänsta sidan innan ([0-9]*)?\n"
" parantes (([1-9][0-9]*\\.)|(\\.[0-9]+))\n"
" Alt1: ([1-9][0-9]*\\.)\n"
" Non Zero leading- siffra sen punkt\n"
" Alt2: (\\.[0-9]+)\n"
" Punkt sen (måste) siffra\n"
" Högra sidan ([0-9]*)?([eE][\\-\\+]?[1-9][0-9]*)?\n"
" ([0-9]*)?\n"
" kanske siffra\n"
" ([eE][\\-\\+]?[1-9][0-9]*)?\n"
" kanske exponent \n"
" \n"
" \n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")