const regex = /0*(\d+)=(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0*(\\d+)=(\\d+)', 'gm')
const str = `blah.php?00153067=1&00153067=198;00153067=123&4439=023blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}