$re = '/0*(\d+)=(\d+)/m';
$str = 'blah.php?00153067=1&00153067=198;00153067=123&4439=023blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);