package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)[\t|\n]`)
var str = `Alabama Ala. AL Montgomery
Illinois Ill. IL Springfield
Wyoming Wyo. WY Cheyenne`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}