re = /(.*?)[\t|\n]/m
str = 'Alabama Ala. AL Montgomery
Illinois Ill. IL Springfield
Wyoming Wyo. WY Cheyenne'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end