$re = '/(.*?)[\t|\n]/m';
$str = 'Alabama Ala. AL Montgomery
Illinois Ill. IL Springfield
Wyoming Wyo. WY Cheyenne';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);