#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^\w+"
Local $sString = "\w = [\p{Ll}\p{Lu}\p{Lt}\p{Lo}\p{Lm}\p{Nd}\p{Nl}\p{No}\p{Pc}] (the \p{Mn} is not included as in .NET regex)" & @CRLF & _
"" & @CRLF & _
"ﬔąфrw𝐚𝒇𝓌𝔨𝕨𝗐𝛌𝛚ὣỷᵺᴔᴉվԍӹӡҁʫ - Ll, lowercase letters (some)" & @CRLF & _
"AÂĞƎƗNJΔΘΣϢЉЩѬӲԽႵᎿᏉᏯԌℬⰏR𝐖 - Lu, uppercase letters (some)" & @CRLF & _
"DžLjNjDzᾈᾉᾊᾋᾌᾍᾎᾏᾘᾙᾚᾛᾜᾝᾞᾟᾨᾩᾪᾫᾬᾭᾮᾯᾼῌῼ - Lt, titlecase letters (all)" & @CRLF & _
"ǃºऌߩהײبܢ - Lo, other letters (some) (note regex101 highlighting is weird here)" & @CRLF & _
"ʰʷˇˣߴߵໆᱽᵂᵒᵝᶣₐ〱ꀕꜛー - Lm, Modifier letters (some)" & @CRLF & _
"e҇c͢ą Mn, nonspacing mark" & @CRLF & _
"09١٨߁߈੮୪௨௫൫๕༥៨᧕᱕5 Nd, decimal digit number (some)" & @CRLF & _
"Ⅲᛯⅷ𒑣 - Nl, letter number" & @CRLF & _
"¼৶౼൵፫⁹⅙ - No, other number" & @CRLF & _
"_‿⁀⁔︳︴﹍﹎﹏_ Only a _ from \p{Pc}, connector punctuation (.NET matches all of them)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")