import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+";
final String string = "\\w = [\\p{Ll}\\p{Lu}\\p{Lt}\\p{Lo}\\p{Lm}\\p{Nd}\\p{Nl}\\p{No}\\p{Pc}] (the \\p{Mn} is not included as in .NET regex)\n\n"
+ "ﬔąфrw𝐚𝒇𝓌𝔨𝕨𝗐𝛌𝛚ὣỷᵺᴔᴉվԍӹӡҁʫ - Ll, lowercase letters (some)\n"
+ "AÂĞƎƗNJΔΘΣϢЉЩѬӲԽႵᎿᏉᏯԌℬⰏR𝐖 - Lu, uppercase letters (some)\n"
+ "DžLjNjDzᾈᾉᾊᾋᾌᾍᾎᾏᾘᾙᾚᾛᾜᾝᾞᾟᾨᾩᾪᾫᾬᾭᾮᾯᾼῌῼ - Lt, titlecase letters (all)\n"
+ "ǃºऌߩהײبܢ - Lo, other letters (some) (note regex101 highlighting is weird here)\n"
+ "ʰʷˇˣߴߵໆᱽᵂᵒᵝᶣₐ〱ꀕꜛー - Lm, Modifier letters (some)\n"
+ "e҇c͢ą Mn, nonspacing mark\n"
+ "09١٨߁߈੮୪௨௫൫๕༥៨᧕᱕5 Nd, decimal digit number (some)\n"
+ "Ⅲᛯⅷ𒑣 - Nl, letter number\n"
+ "¼৶౼൵፫⁹⅙ - No, other number\n"
+ "_‿⁀⁔︳︴﹍﹎﹏_ Only a _ from \\p{Pc}, connector punctuation (.NET matches all of them)";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}