const regex = /^\w+/gum;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+', 'gum')
const str = `\\w = [\\p{Ll}\\p{Lu}\\p{Lt}\\p{Lo}\\p{Lm}\\p{Nd}\\p{Nl}\\p{No}\\p{Pc}] (the \\p{Mn} is not included as in .NET regex)
ﬔąфrw𝐚𝒇𝓌𝔨𝕨𝗐𝛌𝛚ὣỷᵺᴔᴉվԍӹӡҁʫ - Ll, lowercase letters (some)
AÂĞƎƗNJΔΘΣϢЉЩѬӲԽႵᎿᏉᏯԌℬⰏR𝐖 - Lu, uppercase letters (some)
DžLjNjDzᾈᾉᾊᾋᾌᾍᾎᾏᾘᾙᾚᾛᾜᾝᾞᾟᾨᾩᾪᾫᾬᾭᾮᾯᾼῌῼ - Lt, titlecase letters (all)
ǃºऌߩהײبܢ - Lo, other letters (some) (note regex101 highlighting is weird here)
ʰʷˇˣߴߵໆᱽᵂᵒᵝᶣₐ〱ꀕꜛー - Lm, Modifier letters (some)
e҇c͢ą Mn, nonspacing mark
09١٨߁߈੮୪௨௫൫๕༥៨᧕᱕5 Nd, decimal digit number (some)
Ⅲᛯⅷ𒑣 - Nl, letter number
¼৶౼൵፫⁹⅙ - No, other number
_‿⁀⁔︳︴﹍﹎﹏_ Only a _ from \\p{Pc}, connector punctuation (.NET matches all of them)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}