using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?:['""]\s))(\w+)\s*=\s*(['""])([\w\s(?:\\(?!\2))]+)";
string input = @"attr1=""val\""1\"" attr2=""val2a val2b""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}