re = /(?:^|(?:['"]\s))(\w+)\s*=\s*(['"])([\w\s(?:\\(?!\2))]+)/m
str = 'attr1="val\\"1\\"" attr2="val2a val2b"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end