$re = '/(?:^|(?:[\'"]\s))(\w+)\s*=\s*([\'"])([\w\s(?:\\\\(?!\2))]+)/m';
$str = 'attr1="val\\"1\\"" attr2="val2a val2b"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);