package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)iOS[89]|iOS[1][0-3]`)
var str = `iOS7
iOS8
iOS9
iOS10
iOS11
iOS12
iOS13
iOS14`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}