import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "iOS[89]|iOS[1][0-3]";
final String string = "iOS7\n"
+ "iOS8\n"
+ "iOS9\n"
+ "iOS10\n"
+ "iOS11\n"
+ "iOS12\n"
+ "iOS13\n"
+ "iOS14";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}