#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)\b(?:[ptkmnswlj]?[aeiou](?<!ji|ti|wo|wu)n?)(?:(?(?<=n)[ptkswlj][aeiou](?<!ji|ti|wo|wu)n?|[ptkmnswlj][aeiou](?<!ji|ti|wo|wu)n?))*\b"
Local $sString = "panna" & @CRLF & _
"jijin" & @CRLF & _
"titin" & @CRLF & _
"wowu" & @CRLF & _
"wonwun" & @CRLF & _
"tewun" & @CRLF & _
"tetin" & @CRLF & _
"tejin" & @CRLF & _
"teji" & @CRLF & _
"aan" & @CRLF & _
"---" & @CRLF & _
"mama" & @CRLF & _
"seme" & @CRLF & _
"pona" & @CRLF & _
"toki pona li toki suwi" & @CRLF & _
"jan Lili li lili" & @CRLF & _
"" & @CRLF & _
"ni li ilo Lekula Epesen. ni li ken lanpan e nimi mute " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")