const regex = /\b(?:[ptkmnswlj]?[aeiou](?<!ji|ti|wo|wu)n?)(?:(?(?<=n)[ptkswlj][aeiou](?<!ji|ti|wo|wu)n?|[ptkmnswlj][aeiou](?<!ji|ti|wo|wu)n?))*\b/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:[ptkmnswlj]?[aeiou](?<!ji|ti|wo|wu)n?)(?:(?(?<=n)[ptkswlj][aeiou](?<!ji|ti|wo|wu)n?|[ptkmnswlj][aeiou](?<!ji|ti|wo|wu)n?))*\\b', 'mig')
const str = `panna
jijin
titin
wowu
wonwun
tewun
tetin
tejin
teji
aan
---
mama
seme
pona
toki pona li toki suwi
jan Lili li lili
ni li ilo Lekula Epesen. ni li ken lanpan e nimi mute
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}