using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[ptkmnswlj]?[aeiou](?<!ji|ti|wo|wu)n?)(?:(?(?<=n)[ptkswlj][aeiou](?<!ji|ti|wo|wu)n?|[ptkmnswlj][aeiou](?<!ji|ti|wo|wu)n?))*\b";
string input = @"panna
jijin
titin
wowu
wonwun
tewun
tetin
tejin
teji
aan
---
mama
seme
pona
toki pona li toki suwi
jan Lili li lili
ni li ilo Lekula Epesen. ni li ken lanpan e nimi mute
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}