package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ix)\b(?:[ptkmnlswj]?
(?:(?<=w)[aei]|
(?<=[jt])[aeou]|
(?<=[pkmnls])[aeiou]|
(?<=\b)[aeiou])
(?:n(?![nm]?[aeiou]))?)+\b`)
var str = `panna
jijin
titin
wowu
wonwun
tewun
tetin
tejin
teji
aan
---
mama
seme
pona
toki pona li toki suwi
jan Lili li lili
ni li ilo Lekula Epesen. ni li ken lanpan e nimi mute
eni
nanma
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}