import re
regex = re.compile(r"""
\b(?:[ptkmnlswj]?
(?:(?<=w)[aei]|
(?<=[jt])[aeou]|
(?<=[pkmnls])[aeiou]|
(?<=\b)[aeiou])
(?:n(?![nm]?[aeiou]))?)+\b
""", flags=re.IGNORECASE | re.VERBOSE)
test_str = ("panna\n"
"jijin\n"
"titin\n"
"wowu\n"
"wonwun\n"
"tewun\n"
"tetin\n"
"tejin\n"
"teji\n"
"aan\n"
"---\n"
"mama\n"
"seme\n"
"pona\n"
"toki pona li toki suwi\n"
"jan Lili li lili\n\n"
"ni li ilo Lekula Epesen. ni li ken lanpan e nimi mute \n"
"eni\n\n"
"nanma\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")