const regex = /(?:.*?keyword\b|\G(?!^))[^\[\]]*\K[\[\]]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*?keyword\\b|\\G(?!^))[^\\[\\]]*\\K[\\[\\]]', 'gm')
const str = `ab[ cd] ef keyword [ gh ]keyword ij [ ] []`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);