$re = '/(?:.*?keyword\b|\G(?!^))[^\[\]]*\K[\[\]]/m';
$str = 'ab[ cd] ef keyword [ gh ]keyword ij [ ] []';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;