import re
regex = re.compile(r"(?:.*?keyword\b|\G(?!^))[^\[\]]*\K[\[\]]", flags=re.MULTILINE)
test_str = "ab[ cd] ef keyword [ gh ]keyword ij [ ] []"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)