$re = '/.*\K2. \]|.*\K3. \]|.*\K4. \]|.*\K5. \]|.*\K6. \]|.*\K7. \]/s';
$str = '|dart24356- shows [ 8d 9h ]|
|dart24356- shows [ 8d 5h ]|
|dart24356- shows [ Kd Kh ]|
|dart24356- shows [ Qc Ac ] |
|dart24356- shows [ 2d 4h ]|
|dart24356- shows [ 3d 3h ]|
|dart24356- shows [ Kd Kh ]|
|dart24356- shows [ 8d 5h ]|
|dart24356- shows [ Qc Ac ] |';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);