# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.{1,32}\S*\b)/$1|||/gm;t' <<< "Intrepid Air and Space Museum, of ny 46th St And 12th Ave Pier, 86 New York City NY 10036
Impact Christian Church of Woodland Park Colorado Scott Park"