re = /(.{1,32}\S*\b)/m
str = 'Intrepid Air and Space Museum, of ny 46th St And 12th Ave Pier, 86 New York City NY 10036
Impact Christian Church of Woodland Park Colorado Scott Park'
subst = '$1|||'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result