use strict;
my $str = 'Intrepid Air and Space Museum, of ny 46th St And 12th Ave Pier, 86 New York City NY 10036
Impact Christian Church of Woodland Park Colorado Scott Park';
my $regex = qr/(.{1,32}\S*\b)/mp;
my $subst = '$1|||';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";