const regex = new RegExp('^(?:(?:git@github\\.com:)|(?:https://github.com))/?(?P<github_path>(?P<owner>\\w+)/(?P<name>[\\w-]+))(?:\\.git)?$', 'gm')
const str = `https://github.com/argoai/labeling.git
git@github.com:argoai/lme-common.git
git@github.com:/argoai/labeling.git
git@github.com:/argoai/labeling`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}