import re
regex = re.compile(r"^(?:(?:git@github\.com:)|(?:https://github.com))/?(?P<github_path>(?P<owner>\w+)/(?P<name>[\w-]+))(?:\.git)?$", flags=re.MULTILINE)
test_str = ("https://github.com/argoai/labeling.git\n"
"git@github.com:argoai/lme-common.git\n"
"git@github.com:/argoai/labeling.git\n"
"git@github.com:/argoai/labeling")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")