$re = '/(?<=@[A-Za-z]+,\s[A-Za-z]+\[[A-Za-z]+\])\s+|(?<=@[A-Z|a-z]+,)\s+(?![A-Za-z]+\[[A-Za-z]+\])/m';
$str = '@fsfasfsdf, <<<
@sdfJKfsd, <<<
@asdjsdhasLAKJA, <<<
@A, <<<<
@noMatchInThisLine,<<<<<
@sdasdsad, dsajkdlasdfasd[fsadsd] <<<<<<<
@ noMatchInThisLine, <<<<
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);