const regex = /(name)\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(name)\\1', 'g')
const str = `namename name namesake`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);