import Foundation
let pattern = #"(name)\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"namename name namesake"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)