use strict;
my $str = 'namename name namesake';
my $regex = qr/(name)\1/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";