import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!@)\\d(?:\\s*\\d){5}\\b(?!@)";
final String string = "209 016 - should be come up in search result and as 400013(space removed)\n\n"
+ "209016 - should also come up in search and unaltered as 209016\n\n"
+ "any numeric string more then 6 digits long should not come up in search eg 20901677,209016@223123, 29016,\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}