import re
regex = re.compile(r"\b(?<!@)\d(?:\s*\d){5}\b(?!@)", flags=re.MULTILINE)
test_str = ("209 016 - should be come up in search result and as 400013(space removed)\n\n"
"209016 - should also come up in search and unaltered as 209016\n\n"
"any numeric string more then 6 digits long should not come up in search eg 20901677,209016@223123, 29016,\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")