re = /\b(?<!@)\d(?:\s*\d){5}\b(?!@)/m
str = '209 016 - should be come up in search result and as 400013(space removed)
209016 - should also come up in search and unaltered as 209016
any numeric string more then 6 digits long should not come up in search eg 20901677,209016@223123, 29016,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end