#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)abc.*?efg"
Local $sString = "blah blah.." & @CRLF & _
"blah blah.." & @CRLF & _
"blah abc blah" & @CRLF & _
"blah blah.." & @CRLF & _
"blah blah.." & @CRLF & _
"blah blah.." & @CRLF & _
"blah efg1 blah blah" & @CRLF & _
"blah blah.." & @CRLF & _
"blah blah.." & @CRLF & _
"blah efg2 blah blah" & @CRLF & _
"blah blah.." & @CRLF & _
"blah blah.."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")