package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)abc.*?efg`)
var str = `blah blah..
blah blah..
blah abc blah
blah blah..
blah blah..
blah blah..
blah efg1 blah blah
blah blah..
blah blah..
blah efg2 blah blah
blah blah..
blah blah..`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}