const regex = /(?s)abc.*?efg/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)abc.*?efg', 'gm')
const str = `blah blah..
blah blah..
blah abc blah
blah blah..
blah blah..
blah blah..
blah efg1 blah blah
blah blah..
blah blah..
blah efg2 blah blah
blah blah..
blah blah..`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}