#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<Comment (.*?)>"
Local $sString = "<cmt-def id="ea22b676-f439-4afc-b457-f39c15ff3836"> <Comments> <Comment severity="Low" user="PC" date="2016-10-30T20:42:56.0922708+00:00" version="1.0">Kommentar segment 7</Comment> </Comments> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")