$re = '@<Comment (.*?)>@';
$str = '<cmt-def id="ea22b676-f439-4afc-b457-f39c15ff3836"> <Comments> <Comment severity="Low" user="PC" date="2016-10-30T20:42:56.0922708+00:00" version="1.0">Kommentar segment 7</Comment> </Comments> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);