use strict;
my $str = '<cmt-def id="ea22b676-f439-4afc-b457-f39c15ff3836"> <Comments> <Comment severity="Low" user="PC" date="2016-10-30T20:42:56.0922708+00:00" version="1.0">Kommentar segment 7</Comment> </Comments> ';
my $regex = qr@<Comment (.*?)>@p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}