import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:0[1-9]|1\\d|2[0-8])\\/(?:02)\\/(?:\\d+)|(?:0[1-9]|1\\d|2\\d)\\/(?:02)\\/(?:(?:\\d*?(?:(?:(?!00)[02468][048]|[13579][26])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\\D))|(?:0[1-9]|1\\d|2\\d|30)\\/(?:0[469]|11)\\/(?:\\d+)|(?:0[1-9]|1\\d|2\\d|3[01])\\/(?:0[13578]|1[02])\\/(?:\\d+))\\ (?:(?:0\\d|1[01]):(?:[0-5]\\d):(?:[0-5]\\d)(?:\\.(?:\\d{3}))?\\ ?(?:(?i)[ap]m|[ap]\\.m\\.(?-i))|(?:[01]\\d|2[0-3]):(?:[0-5]\\d):(?:[0-5]\\d)(?:\\.(?:\\d{3}))?)\\b";
final String string = "29/02/2016 23:10:59 - valid\n"
+ "29/02/2017 23:10:59 - invalid (not leap year)\n"
+ "30/03/2016 23:10:59 - valid";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}