const regex = /\b(?:(?:0[1-9]|1\d|2[0-8])\/(?:02)\/(?:\d+)|(?:0[1-9]|1\d|2\d)\/(?:02)\/(?:(?:\d*?(?:(?:(?!00)[02468][048]|[13579][26])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D))|(?:0[1-9]|1\d|2\d|30)\/(?:0[469]|11)\/(?:\d+)|(?:0[1-9]|1\d|2\d|3[01])\/(?:0[13578]|1[02])\/(?:\d+))\ (?:(?:0\d|1[01]):(?:[0-5]\d):(?:[0-5]\d)(?:\.(?:\d{3}))?\ ?(?:(?i)[ap]m|[ap]\.m\.(?-i))|(?:[01]\d|2[0-3]):(?:[0-5]\d):(?:[0-5]\d)(?:\.(?:\d{3}))?)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?:0[1-9]|1\\d|2[0-8])\\\/(?:02)\\\/(?:\\d+)|(?:0[1-9]|1\\d|2\\d)\\\/(?:02)\\\/(?:(?:\\d*?(?:(?:(?!00)[02468][048]|[13579][26])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\\D))|(?:0[1-9]|1\\d|2\\d|30)\\\/(?:0[469]|11)\\\/(?:\\d+)|(?:0[1-9]|1\\d|2\\d|3[01])\\\/(?:0[13578]|1[02])\\\/(?:\\d+))\\ (?:(?:0\\d|1[01]):(?:[0-5]\\d):(?:[0-5]\\d)(?:\\.(?:\\d{3}))?\\ ?(?:(?i)[ap]m|[ap]\\.m\\.(?-i))|(?:[01]\\d|2[0-3]):(?:[0-5]\\d):(?:[0-5]\\d)(?:\\.(?:\\d{3}))?)\\b', 'g')
const str = `29/02/2016 23:10:59 - valid
29/02/2017 23:10:59 - invalid (not leap year)
30/03/2016 23:10:59 - valid`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}