package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\s;]+@[^\s;]+`)
var str = `trump;Donald Trump;trump@yahoo.eu
obama;Barack Obama;obama@google.com
bush;George Bush;bush@inbox.com
clinton,Bill Clinton;clinton@mail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}