$re = '/[^\s;]+@[^\s;]+/m';
$str = 'trump;Donald Trump;trump@yahoo.eu
obama;Barack Obama;obama@google.com
bush;George Bush;bush@inbox.com
clinton,Bill Clinton;clinton@mail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);