re = /[^\s;]+@[^\s;]+/m
str = 'trump;Donald Trump;trump@yahoo.eu
obama;Barack Obama;obama@google.com
bush;George Bush;bush@inbox.com
clinton,Bill Clinton;clinton@mail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end