using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"value=""\K\d+(?="")";
string input = @"<option value=""123""></option>
<option value=""412""></option> ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}