re = /value="\K\d+(?=")/
str = '<option value="123"></option>
<option value="412"></option> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end