import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^@import\\s+(?:url\\(['\"]?.*?['\"]?\\)|['\"].*?['\"])(\\s+[^;]+?)?;$";
final String string = "@import url(https://clearvision.github.io/ClearVision-v6/main.css) asd;\n"
+ "@import url(\"https://clearvision.github.io/ClearVision-v6/main.css\") asd;\n"
+ "@import 'https://clearvision.github.io/ClearVision-v6/main.css' asd;\n"
+ "@import url(\"landscape.css\") screen and (orientation: landscape);\n"
+ "@import \"landscape.css\" screen and (orientation: landscape);\n"
+ "@import url(\"flexy.css\") supports(not (display: grid) and (display: flex)) screen\n"
+ " and (max-width: 400px);";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}